Getting rid of "VMware Shared Folders" under OS X

April 1, 2013 Brian Cunnie

The Scenario

You have a fresh machine. But when you log in, you see a link on your desktop to VMware Shared Folders. You drag it to your Trash. Next time you log in, you see it again: VMware Shared Folders. Again, you move it to the Trash. The third time it happens, you wonder, “What the heck is going on? How can I permanently delete VMware Shared Folders?”

The Cause

The most likely cause is that your machine was cloned from an image that was created under a VMware Fusion instance that had VMware Tools installed.

The Easy Fix

The easy fix is to Uninstall VMware Tools. It can be found in /Library/Application Support/VMware Tools.

The Hard Fix

Log in to your workstation and run these commands; they should fix the problem:

for PLIST in
  /Library/LaunchAgents/com.vmware.launchd.vmware-tools-userd.plist  /Library/LaunchDaemons/com.vmware.launchd.tools.plist
do
  [ -f $PLIST ] &&
  sudo defaults write $PLIST RunAtLoad -bool false &&
  sudo plutil -convert xml1 $PLIST &&
  sudo chmod 444 $PLIST
done
rm ~/Desktop/VMWare Shared Folders

The VMware Shared Folders should be gone for good.

The Specs

This has been tested under OS X 10.8.3 and VMware Fusion 5.0.3

Other Clues

Another indication that you’re running a machine that was imaged from a virtual machine with VMware tools installed is that you receive the following message when you run lsof:

lsof: WARNING: can't stat() vmhgfs file system /Volumes/VMware Shared Folders

A Bolder Way

If you know that you’ll never want to re-enable VMware tools, deleting the configuration files may be easier (caveat utor: I have not tried this myself):

sudo rm /Library/LaunchAgents/com.vmware.launchd.vmware-tools-userd.plist /Library/LaunchDaemons/com.vmware.launchd.tools.plist
rm ~/Desktop/VMWare Shared Folders

 

About the Author

Biography

Previous
Xcode Templates
Xcode Templates

Xcode has a little known feature that can save you time, frustration, and ultimately can even improve code ...

Next
Brand New Features in Underscore.js and Backbone.js by Pivots
Brand New Features in Underscore.js and Backbone.js by Pivots

Just wanted to highlight a couple features that @brysgo and I contributed to these libraries using our beac...